RECEIPT BANK

Problème de formules excel

8 réponses
2 356 lectures
Ecrit le : 09/08/2006 12:58 par Fabrice Heuvrard
Bonjour,
j'ai un petit souci avec excel.
Voila j'ai trois colonnes, dans la première je veux mettre la date de facon automatique à partir du moment que je tape quelquechose dans la colonne B.
J'ai donc taper cette formule dans la colonne A
SI(b1="";"";aujourdhui()).
Mais le problème est que excel me renvoie un chiffre et non la date, il me renvoie 38938?
Je ne vois pas ou est mon erreur....
Merci d'avance aux âmes charitables.

--------------------
Expert-comptable et commissaire aux comptes

Re: Problème de formules excel

Ecrit le : 09/08/2006 13:07 par Fabrice Heuvrard
Alors je viens d'avoir la réponse, merci kristen....
Donc en fait il faut paramétrer la cellule au format date car excel paramètre automatiquement en chiffre....
MERCI!

--------------------
Expert-comptable et commissaire aux comptes

Re: Problème de formules excel

Ecrit le : 09/08/2006 13:12 par Johan77
Je me débrouille un peu sur Excel, il me semble que ca marche si et seulement si :-) :

en A1: =SI(B1>0;B1)
en B1: = AUJOURDHUI()


--------------------
Validation du decf en 2007 DECF uv 1, 3 validées , uv 6 en septembre 2006 Bts compta 2005

Re: Problème de formules excel

Ecrit le : 09/08/2006 19:20 par Fabrice Heuvrard
Non johan,
pour info j'ai mis en A1
SI(b1="";"";aujourdhui())

Donc l'écriture de la date sera automatique à partir du moment que quelquechose est rentrée en b1. Il faut bien spécifier que le format de la cellule a1 est date.
Cordialement

--------------------
Expert-comptable et commissaire aux comptes

Re: Problème de formules excel

Ecrit le : 10/08/2006 11:23 par Eclair
Bonjour,

J'ai aussi un souci avec cette fonctionnalité.

Je n'ai pas compris quand vous mettez "" ca veut dire quoi?
Et dans la formule il faut mettre le terme aujourd'hui?

merci

Re: Problème de formules excel

Ecrit le : 10/08/2006 11:51 par Fabrice Heuvrard
Bonjour,
le "" signifie que la cellule est vide.
La fonction aujourdhui va afficher la date automatiquement.
Cordialement

--------------------
Expert-comptable et commissaire aux comptes

Re: Problème de formules excel

Ecrit le : 10/08/2006 12:03 par Eclair
Merci icare!

J'ai essayé mais ca ne marche pas, dans la cellule A1, il apparait "NOM?", j'ai bien mis "ajourd'hui" pourtant!

Re: Problème de formules excel

Ecrit le : 10/08/2006 13:46 par Fabrice Heuvrard
Bonjour éclair,
il faut que tu fasse clic droit sur ta cellule et que tu sélectionne "format de la cellule" puis "date" ainsi tu n'aura plus ce message d'erreur.

--------------------
Expert-comptable et commissaire aux comptes

Re: Problème de formules excel

Ecrit le : 10/08/2006 16:42 par Debitcredit
Bonjour,

EXCEL est aussi rigoureux qu'un comptable !

Pour lui indiquer qu'une cellule contient une formule de calcul, il faut commencer la saisie par un signe arithmétique comme +, - ou =.
Dans ta cellule A1, tu dois donc saisir : =SI(b1="";"";aujourdhui())
D'autre part, si le contenu est une fonction, il ne faut pas oublier les parenthèses et les éventuels paramètres. Dans ton cas, cela devrait être : =aujourdhui()
Si EXCEL trouve simplement =aujourdhui il cherche une zone qui s'appelle "aujourdhui", ne la trouve pas et retourne un message d'erreur.
Twitter   Facebook   Linkedin

Pour poster un nouveau message, vous devez vous enregistrer en tant que membre ou vous connecter à votre compte.
L'inscription est rapide et gratuite !

Inscription nouveau membre   Connexion

Perte de nom d'utilisateur   Perte de mot passe
Comptalia