Bonjour à tous!

Le Sujet zéro de l'UE 8 faisant suite à la réforme du DCG est disponible!

Malheureusement les sujets sont souvent parsemés de "coquilles" et celui-ci ne déroge pas à la règle.

Ainsi DOSSIER 3 Question 2 on nous propose pour contrôler si le contenu de la cellule B9 (Feuille "devis")

respecte bien le formalisme en vigueur soit LL-CCC-LL (L:Lettre;C:Chiffre):

=SI( ET (ESTEXTE (GAUCHE (B9;2));ESTNUM(STXT(B9;4;3);ESTTEXTE (DROITE(B9;2)));"";"Erreur")

La fonction ESTNUM(STXT(B9;4;3) employée içi renverra systématiquement la valeur "FAUX".

Je m'explique:

Pour Excel un nombre est d'abord interprété comme un texte s'il est extrait d'une chaîne de caractère, ici

STXT(B9;4;3). Pour que la formule fonctionne il faut d'abord convertir le résultat en nombre, si cela

produit une erreur alors la chaîne converti contenait du Texte sinon il s'agissait bien d'un nombre.

ESTNUM(STXT(B9;4;3)

Devient:

SI (ESTERREUR (CNUM(STXT(B9;4;3));FAUX;VRAI)

Attention la conditionnelle renvoi içi des valeurs de type Booléens (VRAI/FAUX) et non le texte( Pas de

guillemets)