CEGID

Aide pour formule de calcul

5 réponses
874 lectures
Ecrit le : 26/11/2013 08:28 par Carole0809

Bonjour à tous,

Voilà, j'aurais besoin de votre aide pour la mise en place d'une formule de calcul.

j'ai un tableau excel (ci-joint), et j'ai besoin de mettre dans une 2ème colonne la formule de calcul qui indique que si la somme de ma colonne A est comprise entre 1 et 7, la somme de cette colonne est multipliée par 1.25. Par contre si la somme de ma colonne est supérieure à 7 alors on multiplie la somme de ma colonne par 1.5.

J'ai essayé, mais ça m'indique Valeur dans la colonne ! il y a un truc que j'ai du mal faire, mais je ne vois pas quoi... (bon il était très tard hier soir quand je m'y suis mise, c'est peut-être pour ça....)

Merci par avance à ceux et celles qui pourront m'apporter leur lumière.

Bonne journée



(Nombre de téléchargements: 3)
Heures-supp.xlsx
Pour télécharger des fichiers, vous devez vous enregistrer en tant que membre ou vous connecter à votre compte.
L'inscription est rapide et gratuite !

Inscription nouveau membre   Connexion

Perte de nom d'utilisateur   Perte de mot passe


--------------------
Carole

Re: Aide pour formule de calcul

Ecrit le : 26/11/2013 10:00 par Lucky luc

Bonjour,

Une parenthèse mal placée et un "SOMME" manquant. Voici la formule corrigée (j'ai aussi remplacé < par <= au vu de la rédaction de l'objectif de la formule) :

=SI(SOMME(B3:B7)<=7;SOMME(B3:B7)*1,25;SOMME(B3:B7)*1,5)

Cordialement.



--------------------
DECF - DEFC - Maîtrise ès Sciences Économiques - DESS Techniques Quantitatives et Informatiques de Gestion

Re: Aide pour formule de calcul

Ecrit le : 26/11/2013 13:24 par Carole0809

Bonjour Lucky,

Merci encore !

zut j'ai louché alors !!!

Merci et bonne journée



--------------------
Carole

Re: Aide pour formule de calcul

Ecrit le : 26/11/2013 23:29 par Carole0809

heu... bonsoir c'est encore moi...

en fiat, j'ai encore un souci avec cette formule de calcul ! désolée, mais on ne m'a pas vraiment toutes les infos hier donc....

En fait, les heures entre 1 et 7 h sont majorées de 25%, et au-delà de 7h c'est 50%.... ce qui signifie que ma formule est fausse ! hé oui, ma formule calcule soit jusqu'à 7 h et 25%, soit si c'est au-delà, 50%... mais en fait, il faut qu'elle cumule les deux calculs.... vous me suivez ???

je vais essayer de voir si je trouve la bonne formule, mais sinon si quelqu'un peut encore m'éclairer, merci d'avance.

Bonne soirée



--------------------
Carole

Re: Aide pour formule de calcul

Ecrit le : 27/11/2013 00:09 par Lucky luc

Bonsoir,

7 heures ? Pour les heures supplémentaires, légalement, le changement se fait après la huitième heure.

Mais je vais raisonner avec 7.

Une majoration de 25% jusqu'à 7 puis de 50% revient à majorer l'ensemble des heures de 25% et de rajouter 25% au delà de 7 heures.

=SOMME(B3:B7)+SOMME(B3:B7)*0,25+SI(SOMME(B3:B7)>7;(SOMME(B3:B7)-7)*0,25;0)

ou en simplifiant =SOMME(B3:B7)*1,25+SI(SOMME(B3:B7)>7;(SOMME(B3:B7)-7)*0,25;0)

6 heures donnent 6 x 1,25 + 0 = 6 x 1,25

8 heures donnent 8 x 1,25 + ((8-7) x 0,25) = 8 x 1 ,25 + 1 x 0,25 = (7 x 1,25 + 1 x 1,25) + 1 x 0,25 = 7 x 1,25 + ( 1 x 1,25 + 1 x 0,25) = 7 x 1,25 + 1 x 1,50 (7 heures payées 25% en supplément, celle au delà payée 50%)

Cordialement.

PS : le raisonnement se faisait ici sans le taux horaire. Sur le bulletin de paye, on ne présente pas un nombre d'heures gonflé comme le donnerait ce calcul mais on applique un taux horaire majoré de 25% et 50% au nombre d'heures effectuées pour les 2 catégories d'heures supplémentaires..



--------------------
DECF - DEFC - Maîtrise ès Sciences Économiques - DESS Techniques Quantitatives et Informatiques de Gestion

Re: Aide pour formule de calcul

Ecrit le : 27/11/2013 21:09 par Carole0809

Encore merci Lucky,

c'est bon j'ai compris. Même si ça n'est pas évident de mettre en place la formule.

Bonne soirée, et merci.



--------------------
Carole
Twitter   Facebook   Linkedin

Pour poster un nouveau message, vous devez vous enregistrer en tant que membre ou vous connecter à votre compte.
L'inscription est rapide et gratuite !

Inscription nouveau membre   Connexion

Perte de nom d'utilisateur   Perte de mot passe
RECEIPT BANK